[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Dedicated grub2 partition

From: Goh Lip
Subject: Re: Dedicated grub2 partition
Date: Mon, 04 Oct 2010 21:07:40 +0800
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100922 Thunderbird/3.1.4

On Monday 04,October,2010 06:36 PM, Barry Jackson wrote:
On 04/10/10 00:57, Goh Lip wrote:
On Monday 04,October,2010 07:48 AM, Goh Lip wrote:
Barry, try this.......


menuentry "PCLOS live iso" {
loopback loop (hd0,x)/<path>/pclinuxos-lxde-2010.1.iso
linux (loop)/isolinux/vmlinuz findiso=/<path>/pclinuxos-lxde-2010.1.iso
boot=isolinux quiet noeject noprompt
initrd (loop)/isolinux/initrd.gz

Hi Goh
Since the .iso is in the root of sda1, the <path> is not actually needed.
I have tried many variations on this:-

menuentry 'PCLOS live iso' {
loopback loop (hd0,1)/pclinuxos-lxde-2010.1.iso
linux (loop)/isolinux/vmlinuz findiso=/pclinuxos-lxde-2010.1.iso
boot=isolinux quiet noeject noprompt
initrd (loop)/isolinux/initrd.gz

> I changed to boot=boot, livecd=livecd, boot=livecd and the result is
> always the same:-

Barry, I forgot about "boot=live"  - let's try that

menuentry "PCLOS live iso" {
loopback loop (hd0,1)/pclinuxos-lxde-2010.1.iso
linux (loop)/isolinux/vmlinuz findiso=/pclinuxos-lxde-2010.1.iso boot=live quiet noeject noprompt
initrd (loop)/isolinux/initrd.gz

ACPI: Aborted because no cpio magic.
Kernel panic - not syncing: No init found. Try passing init= option to

I tried adding noacpi but no change.

With the findiso= the initrd won't boot - without it it runs and gets as
far as detecting all hardware, then searches all devices for the "loop
image" by which I am guessing it means livecd.sqfs ?
I tried livecd=(loop)/livecd but no change.

The 'old' way was to use 'isofrom=/dev/sda1/<path_to>/xxx.iso' instead of 'findiso=/<path_to>/xxx.iso' (note: no longer need /dev/sdax)

So if we use old method, it would be....

menuentry "PCLOS live iso" {
loopback loop (hd0,1)/pclinuxos-lxde-2010.1.iso
linux (loop)/isolinux/vmlinuz isofrom=/dev/sda1/pclinuxos-lxde-2010.1.iso boot=live quiet noeject noprompt
initrd (loop)/isolinux/initrd.gz

That might be worth a try,

I have only 1GB ram - just a thought.

Understand your thinking - but unless we use 'toram' (that sends everthing to ram, useful for cdrom live), that should not make much difference, but we'll keep this in mind.

Thinking back, there was a livecd which require a 'password' which I had put in the linux (kernel) line to boot. But I forgot which livecd that was and goes something like "key=xxxxx", or "key=nokey" but I don't think pclinuxos requires that.

 > Thought you've got these booted?, but never mind, we'll handle the
 > iso boot first, ya?

Yes - I did say "Off topic" that is another issue. It happens if I try
to use the motherboard SATA controllers (nforce3). I have no problems at
all using a PCI Silicon Image SATA card with the grub.cfg I paste binned
earlier. Forget that issue for now!



Good luck. - Goh Lip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]