[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub doesn't boot Debian after boot menu

From: Andre Bischof
Subject: grub doesn't boot Debian after boot menu
Date: Tue, 31 Aug 2010 11:10:27 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20100805 Lightning/1.0b1 Icedove/3.0.6 ThunderBrowse/


I guess I've done something wrong with the last update of grub2. It could also be that I messed up the files /boot/grub/grub.cfg and files in /etc/grub.d as I played with getting an nice splash screen in a bigger resolution.

grub2 shows my boot menu as it was before, but if I choose an entry my monitor switches to black, and nothing happens - neither error messages nor boot output appears, no activity from the HD - simply nothing.

I can boot into my system with "Super Grub2 CD" - it scans my system and gives me boot entries which I can start.

If I look up a functional boot entry from the CD with "e", it shows:

set root=hd0,1
linux /boot/vmlinuz-... root=UUID=... ro
initrd /boot/initrd.img-...

I tried putting that in /etc/grub.d/40_custom, doing update-grub, and it shows up in the boot menu - but if I select it, the problem as described above remains.

I then tried editing an existing entry like this one:

# cat /boot/grub/grub.cfg
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Debian GNU/Linux, with Linux 2.6.32-trunk-686-bigmem' --class debian --class gnu-linux --class gnu --class os {
        insmod part_msdos
        insmod ext2
        set root='(hd1,msdos1)'
search --no-floppy --fs-uuid --set b7c8adf9-9e3f-49ff-b840-801f3ea3b63d
        echo    'Loading Linux 2.6.32-trunk-686-bigmem ...'
linux /boot/vmlinuz-2.6.32-trunk-686-bigmem root=UUID=b7c8adf9-9e3f-49ff-b840-801f3ea3b63d ro quiet
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initrd.img-2.6.32-trunk-686-bigmem

putting set root='(hd1,msdos1)' to set root='(hd0,1)',

but without success.

I did update-grub as well as grub-install /dev/sda and grub-install /dev/hda gemacht, without success too.

/dev/sda1 should be the starting partition - I bootet Knoppix CD only, mounted sda1, there seems to be everything as it should.

I guess the problem is with grub being installed only on one of my disks (sda), not on hda, so grub runs to Nirvana after selecting something in the boot menu.

Any hints how to solve or debug that? Any help is greatly appreciated!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]