[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

error: no such disk

From: Nick Martin
Subject: error: no such disk
Date: Thu, 24 Dec 2009 20:23:42 +0000

Hello list,

I'm having trouble getting grub 2 to work. I've tried installing 2
different distros of Linux (Fedora 12 & Ubuntu 9.10), but grub hasn't
worked on either. I'm getting "error: no such disk", followed by a
grub rescue prompt. When I do "ls" at this prompt, I see this:

    (hd0) (hd0,1) (hd0,2) (hd1,1) (hd1,2) (hd1,3) (hd1,4)

This seems perfectly reasonable. My setup is as follows:

2 ATA hard drives:
/dev/sda (hd0) "master"
    /dev/sda1 (hd0,1) fat32 - Windows XP backup partitionDisk
/dev/sda: 40.0 GB, 40020664320 bytes
    /dev/sda2 (hd0,2) ntfs - Windows XP
/dev/sdb (hd1) "slave"
    /dev/sdb1 (hd1,1) ntfs - storage space
    /dev/sdb2 (hd1,2) ext2 - /boot - uuid=d53965e1-bcb1-4158-8531-193af32d52e7
    /dev/sdb3 (hd1,3) swap
    /dev/sdb4 (hd1,4) ext4 - / - uuid=17a9cefd-3754-4048-9aa9-93dc7967a107

Output from "fdisk -l":

Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe156a499

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         595     4779306    b  W95 FAT32
/dev/sda2   *         596        4865    34298775    7  HPFS/NTFS

Disk /dev/sdb: 251.0 GB, 251000193024 bytes
255 heads, 63 sectors/track, 30515 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x43393f15

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       28684   230400000    7  HPFS/NTFS
/dev/sdb2   *       28685       28708      192780   83  Linux
/dev/sdb3           28709       28890     1461915   82  Linux swap / Solaris
/dev/sdb4           28891       30515    13052812+  83  Linux

GRUB is installed on the mbr of hd0, which is the drive the BIOS boots
from. I've attached my grub.cfg and file. The
file looks correct to me. At the start of the cfg file, grub seems to
be setting up the graphics, for which it needs a font on /dev/sdb4,
which is ext4. I see it uses insmod ext2. Is this right?

I've tried to fix the problem with a liveCD by chrooting into those
partitions and doing update-grub, then grub-install /dev/sda. I'm
using GNU GRUB 1.97~beta4.

Any help would be greatly appreciated. I have no idea what could be
wrong. I'll gladly post more of my config files. Happy holidays

Nick Martin

Attachment: grub.cfg
Description: Binary data

Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]