[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub2 halts on kernel command - SOLVED (by new installation)

From: Tom H
Subject: Re: grub2 halts on kernel command - SOLVED (by new installation)
Date: Tue, 24 Nov 2009 21:09:20 +0100

>>> Since your shell is "grub> ", your kernel command is "kernel", and your
>>> partitions are numbered starting from 0, you are running grub1 not
>>> grub2.

>> Uh oh. Have to check that. Maybe the "Super Grub Disk" runs grub1, but at
>> installation time Ubuntu setup asked me whether I would like to use grub2
>> - and I agreed. Phew, but in the meantime I may have overwritten the
>> setup-time MBR by re-installing it via the Super Grub Disk - which may
>> have replaced it by a grub1 version.

Probably correct. :(

>>> Is your / an ext4 filesystem? AFAIK, grub1 will not recognize ext4.

>> Yes, it's ext4. So this could be the problem ... I'm using grub1 (at
>> least in "diagnosis" mode with the Super Grub Disk) and try to boot
>> an ext4 filesystem...

>> Now this seems to be an explanation why I do not get to a result while
>> diagnosing the boot process with the Super Grub Disk. However, I'm
>> afraid the real problem persists - that is, without any additional tool
>> (like the Super Grub Disk), the system would not boot but just freezes
>> before I get any grub messages.

>> I will try if I find out something now that you gave me an important hint
>> (grub1 vs. grub2). Next action: try to reinstall grub2 in my MBR.

Glad to help.

In this case your problem was that you were using grub1 with ext4 so
SGD would not have helped. I assume that they will create a grub2 disk
at some point although grub2 has a rescue cli, as well as a normal
cli, which AFAIK should allow you to boot without resorting to any
other tool.

>>> PS: What is "dfisklu"?

>> Oops, *hem* ... sorry, should read: "fdisklu" ;) (grub command)

OK, thanks. Just in case someone googles his/her way here, fdisklu is
a Super Grub Disk command (had googled dfisklu without success but
fdisklu is explained).

> I abandoned the whole playing around with grub2 and just re-installed
> Ubuntu Server 64-bit 9.10 with an USB flash drive which I created with
> usb-creator (under Ubuntu Network Remix 9.10). This time, it worked.
> At the installation it asked me about grub2 and I directed the
> installation routine to use /dev/sda. Worked flawlessly, can boot now.

Great! Although it would have been faster to re-install grub2 only.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]