[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub error: Destination address too large

From: Konrad Mohrfeldt
Subject: Grub error: Destination address too large
Date: Wed, 09 Sep 2009 13:42:50 +0200
User-agent: Thunderbird (X11/20090817)


i have mainboard with an onboard Via C3 Samuel 2 @ 800Mhz and want to use it as a little home server. The system has 512MB of RAM and a PCI modem. I can post the exact specs later if necessary (address@hidden atm). My OS of choice is Debian 5 and I'm installing it from a netinst CD. The installation target is a 4GB Panasonic Class 2 SD Card connected via a one of those Hong-Kong-Ebay-IDE2SD-Converters :).

I first tried to install Gentoo but this fails when I try to chroot (segmentation fault). This also happened to me when I booted from an Crunchbang Linux Live CD.

Then i downloaded the netinst iso and tried to install Debian. Using this guide ( I selected manual partitioning, created a 4GB ext2 Partition (ext3 has journaling - probably not the best for an SD Card) with mount option noatime and boot flag. No swap partition.

When installation of the base system finished i selected nothing from tasksel (not even standard system - maybe thats the problem?).


I did the installation process two times because I tried to install grub on /dev/hda and /dev/hda1. But every time I get an error message saying that grub install failed. Reselecting the grub install task from the debian installer menu didn't help (actually the installer seems to refuse to do anything on the sd card after trying to install grub the first (and failed) time in the installation process). Well, not giving up hope of a nice debian system i downloaded a "SuperGrubDisk" iso and started grub. I first tried to use the default boot option resulting in the subjects error message. I then tried to type in the necessary information on my own.

root (hd0,1) - success
linux /boot/vmlinuz... ro single root=/dev/hda1 - success, i also tried uuid for root parameter
initrd /boot/initrd... - success
boot - failed: error: Destination address too large.

That's the point I'm stuck now.

If you need any additional system informationen i'll try to get it when I'm @ home again.

Any help is much _much_ appreciated!



PS: Just for the sake of completeness: The Via C3 Samuel 2 only supports i486 if you define i686 as i686 + cmov. The CPU does not support cmov instruction.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]