[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: finding the hork point in ~/.emacs

From: ken
Subject: Re: finding the hork point in ~/.emacs
Date: Fri, 28 Aug 2020 07:56:17 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 8/28/20 2:41 AM, Eli Zaretskii wrote:
>> From: ken <>
>> Date: Thu, 27 Aug 2020 18:40:54 -0400
>>> What additional mode is that?  How do you turn it on?
>> It's a super-old package, still in quite a bit of use, called
>> html-helper-mode.  I've come to love it a lot, way more than emacs'
>> native html editor.  I've customized it quite a bit over the years
>> also.  Today I went through the whole thing (over 2600 lines for your
>> carpal tunnel pleasure) and tested every function and definition etc.,
>> and everything worked.  And when I got to the last line, it was loaded,
>> So I opened a test.html file, used it in all kinds of ways, and
>> everything worked fine.  So I'm fairly certain that it's some other code
>> before that's invoked which is bringing about the error.
>> It's turned on with this in my ~/.emacs:
>> (autoload 'html-helper-mode "html-helper-mode" "Yay HTML" t)
> So if you start Emacs without that line, and then evaluate that line
> via "M-:", everything works as expected with that mode?  But if that
> line is present in your .emacs, something doesn't work well, is that
> right?  If so, what exactly doesn't work in the latter case?

Thanks for your continuing interest in my problem(s).  Answering your
question in another way (I believe), yesterday when html-helper-mode
wasn't operative at all, as if it wasn't loaded at all, I went into the
html-helper-mode.el file and evaluated (executed with C-x C-e at the end
of every defun and defvar etc.), none of them errored out and
html-helper-mode worked, and AFAICT worked completely.  That would seem
to eliminate it as the source of the problem, yes?

Moreover, and quite strangely, since then every time I've restarted
emacs, html-helper-mode has loaded and worked fine.  And, no, of course
I haven't made any changes to either html-helper-mode.el or to .emacs
(well, nothing at all substantive or relevant).  So that problem seems
to have magically disappeared.

However, now I'm having a very strange problem with tramp, one unrelated
to html of any kind.  I'll describe that in a separate post.  But it's
very strange how the problem seems to be bouncing around, appearing in
different parts of my unchanged code.  Is that even conceivable?  I
would think that I have a problem with some bad RAM, but emacs is the
only thing I'm having problems with, having no problem in any other
software on my system (nothing I've perceived, anyway).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]