[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: finding the hork point in ~/.emacs

From: ken
Subject: Re: finding the hork point in ~/.emacs
Date: Thu, 27 Aug 2020 18:40:54 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 8/27/20 1:42 PM, Eli Zaretskii wrote:
>> From: ken <>
>> Date: Thu, 27 Aug 2020 13:24:51 -0400
>>> So you need to tell more about the problems you see: what exactly
>>> leads you to believe that something in the init file is not working?
>> Good question.  There is an "add-on", an additional mode which my .emacs
>> gets started, but it doesn't get started.  My understanding is that the
>> error would be before that code, yes?
> It could be before, or it could be in that mode.

OKay, I suspected that, wasn't sure.  Makes sense.  Best to hear it from
an expert.

> What additional mode is that?  How do you turn it on?

It's a super-old package, still in quite a bit of use, called
html-helper-mode.  I've come to love it a lot, way more than emacs'
native html editor.  I've customized it quite a bit over the years
also.  Today I went through the whole thing (over 2600 lines for your
carpal tunnel pleasure) and tested every function and definition etc.,
and everything worked.  And when I got to the last line, it was loaded,
So I opened a test.html file, used it in all kinds of ways, and
everything worked fine.  So I'm fairly certain that it's some other code
before that's invoked which is bringing about the error.

It's turned on with this in my ~/.emacs:

(autoload 'html-helper-mode "html-helper-mode" "Yay HTML" t)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]