[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacs + lispy + outline + elipsis NOT showing

From: TongKe Xue
Subject: emacs + lispy + outline + elipsis NOT showing
Date: Wed, 3 Jan 2018 23:06:55 -0700

my lispy + outline config looks something like this:

== begin snip ==
(progn ;; * outline mode
  (setq my-outline-regexp
(concat "^(\\|\\(^\\s-*(" (regexp-opt '("progn " "def" "do ")) ".*\\)"))

  ;; (setq outline-level 'my-outline-level)
  ;; (setq outline-regexp my-outline-regexp)

  (defun my-get-level (s) (length (car (split-string s "("))))

  (defun my-outline-level ()
(if (re-search-backward my-outline-regexp nil t)
    (+ 1 (my-get-level (match-string 0) ))
  (add-hook 'lispy-mode-hook
    (lambda ()
      (setq-local outline-regexp my-outline-regexp)
      (setq-local outline-level 'my-outline-level)))

== end snip ==

Now, when I ortg-cycle on the top level progn (see attached), the three
images we get are:

all closed
partial open
all open

but notice: there is no ellipsis of "..." anywhere when the folds are

Question: how do I debug this / how do I turn on "show ... when collapsed" ?

==== pre-emptikve answers:

1. What is org-ellipsis ? have you tried setting it?

It is 'nil' which according to docs, defaults ot "..." ; I have tried setq
and setq-local on it, nothing happens.

==== bounty / screen sharing help

In case this is difficult to resolve over email and requires interaction /
real time discussion:

On two different freelancing sites, I have posted a $50 bounty for help
resolving this.

If anyone is willing to jump on video chat / screen sharing to help me
debug this, I would be happy to pay $50 (via paypal) for a solution.

This is payment for result, not for time -- so if you try to help me, but
we can't resolve the issue, there will be no payment.


[image: Inline image 6][image: Inline image 5][image: Inline image 4]

PNG image

PNG image

PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]