help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: file dependency list for emacs 24.5 on RHEL


From: Alexis
Subject: Re: file dependency list for emacs 24.5 on RHEL
Date: Mon, 11 Jan 2016 17:58:10 +1100


Dan Espen <address@hidden> writes:

Dahvyd Wing <address@hidden> writes:

Hi All,

I've asked my system admin to install emacs 24.5 on my university's computing farm which uses RHEL. He needs to know what the file dependencies are for the emacs.

I doubt this.

I've looked around and I can't find a list. How do you find a list of dependencies for emacs?

You use the package manager and it automatically finds and installs any dependencies.

Well, the most recent version of CentOS only has Emacs 24.3:

http://mirror.centos.org/centos/7.2.1511/os/x86_64/Packages/

My guess is that this iss an upper bound on what versions of Emacs are provided by RHEL, assuming the latter doesn't have some sort of Debian-like 'backports' repo. If that's so, then 24.5 might need to be manually compiled, hence the request for a list of dependencies.

Perhaps one could install the latest available Emacs source RPM, and examine which library dependencies get pulled in? That might list many, if not most, of the dependencies - at least in terms of library /names/, since the version numbers required for 24.5 might be different.

i'm not a user of RHEL or CentOS, though. :-)


Alexis.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]