help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Company not working in emacs-lisp-mode


From: Dmitry
Subject: Re: Company not working in emacs-lisp-mode
Date: Thu, 17 Jul 2014 03:44:03 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.92 (gnu/linux)

Thorsten Jolitz <address@hidden> writes:

> although company-elisp is part of my company backends
>
> ,----[ C-h v company-backends RET ]
> | company-backends is a variable defined in `company.el'.  Value:
> | (company-cider company-elisp company-bbdb company-nxml company-css
> | company-eclim company-semantic company-clang company-xcode
> | company-cmake (company-dabbrev-code company-gtags company-etags
> | company-keywords) company-oddmuse company-files company-dabbrev
> | company-ispell)
> ...
> it does not work for me, although it worked out of the box in other
> modes. 'does not work' means nothing happens, as if company is not
> activated, but is is shown in the mode line.

I've just tried the current master in an empty Emacs 24.3 session
(started with -Q), and it worked as expected. Have you tried this?

You might have to bisect your configuration.

> however, I frequently see messages like
>
> ,----
> | Company: An error occurred in auto-begin
> | Symbol's function definition is void: company-capf
> `----

Are you sure this error happens in the same kind of buffers where you've
pressed `C-h v company-backends RET' and saw the value without
`company-capf'?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]