help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Company not working in emacs-lisp-mode


From: Grant Rettke
Subject: Re: Company not working in emacs-lisp-mode
Date: Wed, 16 Jul 2014 21:49:51 -0500

My Emacs has a lot of random behavior like that happen when I've got
desktop-mode open and make changes. desktop-mode caches all of the
hook code and reloads it from the cache instead of the init file. Not
saying you are facing this, but perhaps something similar.
Grant Rettke | ACM, ASA, FSF, IEEE, SIAM
address@hidden | http://www.wisdomandwonder.com/
“Wisdom begins in wonder.” --Socrates
((λ (x) (x x)) (λ (x) (x x)))
“Life has become immeasurably better since I have been forced to stop
taking it seriously.” --Thompson


On Wed, Jul 16, 2014 at 8:02 PM, Thorsten Jolitz <address@hidden> wrote:
> Dmitry <address@hidden> writes:
>
>> Thorsten Jolitz <address@hidden> writes:
>>
>>> although company-elisp is part of my company backends
>>>
>>> ,----[ C-h v company-backends RET ]
>>> | company-backends is a variable defined in `company.el'.  Value:
>>> | (company-cider company-elisp company-bbdb company-nxml company-css
>>> | company-eclim company-semantic company-clang company-xcode
>>> | company-cmake (company-dabbrev-code company-gtags company-etags
>>> | company-keywords) company-oddmuse company-files company-dabbrev
>>> | company-ispell)
>>> ...
>>> it does not work for me, although it worked out of the box in other
>>> modes. 'does not work' means nothing happens, as if company is not
>>> activated, but is is shown in the mode line.
>>
>> I've just tried the current master in an empty Emacs 24.3 session
>> (started with -Q), and it worked as expected. Have you tried this?
>
> Right now I tried it, and it works.
>
>> You might have to bisect your configuration.
>
> yes
>
>>> however, I frequently see messages like
>>>
>>> ,----
>>> | Company: An error occurred in auto-begin
>>> | Symbol's function definition is void: company-capf
>>> `----
>>
>> Are you sure this error happens in the same kind of buffers where you've
>> pressed `C-h v company-backends RET' and saw the value without
>> `company-capf'?
>
> no, it seemed to happen 'randomly'. I happened e.g. in emacs-lisp-mode
> but not in the scratch-buffer, that gives me at least a hint when
> looking at the activated minor-modes.
>
> Thanks for the tip.
>
> --
> cheers,
> Thorsten
>
>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]