help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: beginner questions


From: JohnF
Subject: Re: beginner questions
Date: Sun, 29 Sep 2013 07:27:41 +0000 (UTC)
User-agent: tin/2.0.0-20110823 ("Ardenistiel") (UNIX) (NetBSD/5.1.2 (i386))

Pascal J. Bourguignon <address@hidden> wrote:
> JohnF <address@hidden> writes:
> 
>> Two more questions, please. First (as also mentioned in post
>> further down this thread), when I earlier said that fundamental-mode
>> stops parentheses matching, I'd only actually checked <stuff>.
>> Unfortunately, it still matches (stuff), [stuff], {stuff}.
>> Any way to turn that all off?
> 
> M-x customize-variable RET blink-matching-paren RET

Thanks again, Pascal. That works great (and the elisp example
it provides by rewriting the .emacs file is terrific, too).
Only rhetorical question is why I couldn't manage to find that while
trying to google the answer myself, before posting the question.

>>    Secondly, I figured I could easily get that fundamental-mode, as
>> well as other initializations, into .emacs by myself with a little
>> googling. But I tried all of (separately and together)
>>    ; -*- mode: Fundamental;-*-

Aside: I'm sure you realize I'm writing (trying to write)
   "; [dash][asterisk][dash] mode: etc"
above, although it shows up on my reader as a bold asterisk
without dashes.

>    ;; -*- mode: fundamental;-*-

I thought I'd googled that particular "executable comment" with
one semicolon, but I'm currently failing to re-locate the page
that contained the explanation. I'd understood it kind of like
a postscript file comment that actually gets interpreted.
Anyway, I changed it to two semicolons like you suggest,
and it seems to work (both ways, as far as I can tell).

>>    (setq-default major-mode 'fundamental-mode)
>>    (setq major-mode 'fundamental-mode)
> 
> M-x customize-variable RET default-major-mode RET

That coughs up a [No match], although it does recognize
a major-mode variable. But that's already set to
fundamental-mode, probably thanks to your auto-mode-alist
suggestion below, which solved the problem.

>>    (fundamental-mode)
>> and nothing works. Still comes up in its own default mode.
> 
> You should also set auto-mode-alist
>   (setq auto-mode-alist '(("." . fundamental-mode)))

Yup, that solved the problem. And googling your answers
(e.g., googling blink-matching-paren) nicely fills in the
explanations of what's going on (once I know the answer,
it's a lot easier to google it:). Now I'll have to find a
quick-and-dirty elisp tutorial (tried googling bnf elisp,
but could only find useful stuff for bnf lisp) to learn
just enough to init emacs entirely to my liking.
But, thanks mostly to your answers here, I can now see that's
all easily do-able, and can probably easily figure out how.
Thanks again,
-- 
John Forkosh  ( mailto:  address@hidden  where j=john and f=forkosh )


reply via email to

[Prev in Thread] Current Thread [Next in Thread]