help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Strange characters produced by M-x in emacs -nw


From: Harry Putnam
Subject: Re: Strange characters produced by M-x in emacs -nw
Date: Fri, 20 Sep 2013 12:51:55 -0400
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.0.92 (gnu/linux)

address@hidden (Aurélien DESBRIÈRES) writes:

> Harry Putnam <address@hidden> writes:

[...]

>> (I hope these characters are reproduced in this post)
>>
>> `M-x' produces   'ø'
>> `M-Shift + !' produces '¡'
>> `M-shift + :  produces 'º'
>>
>> What kind of setting is likely to be causing this?

[...]

Aurélien Wrote
> xterm*metaSendsEscape: true
>
> to your ~/.Xresources
>
> should correct your trouble.

doesn't seem to do a thing here:

grep 'xterm\*meta' ~/.Xresources

  xterm*metaSendsEscape:        true
     
Followed by closing down X and restarting with startx.

but still if I run `emacs -nw' in an xterm:

And try to press Alt-x, I get this:

  `ø'

I haven't worked on the other cures yet, but pretty sure changing
xmodmap will do the job... just wanted to mention that your suggestion
seems not to work here.

Env is: Debian Linux running on PC (an older P4) using
the real xterm... not any of the pretenders.

 xterm -version
XTerm(295)




reply via email to

[Prev in Thread] Current Thread [Next in Thread]