help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Strange characters produced by M-x in emacs -nw


From: Harry Putnam
Subject: Re: Strange characters produced by M-x in emacs -nw
Date: Fri, 27 Sep 2013 18:04:05 -0400
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.0.92 (gnu/linux)

Harry Putnam <address@hidden> writes:

[...]

> Aurélien Wrote
>> xterm*metaSendsEscape: true
>>
>> to your ~/.Xresources
>>
>> should correct your trouble.
>
> doesn't seem to do a thing here:
>
> grep 'xterm\*meta' ~/.Xresources
>
>   xterm*metaSendsEscape:      true
>      
> Followed by closing down X and restarting with startx.
>
> but still if I run `emacs -nw' in an xterm:
>
> And try to press Alt-x, I get this:
>
>   `ø'

This might be interesting to anyone who followed this thread.

I posted my problem on gmane.comp.freedesktop.xorg.

It resulted in this 2 msg thread.

http://thread.gmane.org/gmane.comp.freedesktop.xorg/49490

Briefly put, Troy K, had this to say:

,----
|   Edit ${HOME}/XTerm and add the following lines:
|   *vt100.altIsNotMeta: true
|   *vt100.altSendsEscape: true
| 
|   Then start a new xterm.
`----

It worked here...  No more mystery char when pressing ALT + <whatever>





reply via email to

[Prev in Thread] Current Thread [Next in Thread]