help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: TRAMP mulihop stopped working after updating to 24.3.50.1


From: Michael Albinus
Subject: Re: TRAMP mulihop stopped working after updating to 24.3.50.1
Date: Sat, 23 Feb 2013 10:18:52 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

Alejandro <address@hidden> writes:

> Hi:

Hi,

> I configured TRAMP to use a multihop connection for some domains. I
> use the following configuration:
>
> (add-to-list 'tramp-default-proxies-alist '("destination.example.com"
> nil "/ssh:address@hidden:"))
>
> This was working until the last update of emacs. Now when I try to
> open a file in destination.example.com, I get the following error:
>
> Tramp: Waiting for prompts from remote shell
> Tramp: Sending command `exec ssh -l user -o
> ControlPath=/tmp/address@hidden:%p -o ControlMaster=auto -o
> ControlPersist=no -e none hop.com'
> Tramp: Opening connection for address@hidden using ssh...done
> byte-code: Args out of range: 68, 106
>
> I'm running GNU Emacs 24.3.50.1 (x86_64-pc-linux-gnu, GTK+ Version
> 3.6.0) of 2013-02-15 on wani04, modified by Debian.
>
> Any idea about how to fix this?

There was an error when I have introduced ControlMaster options to all
ssh-based methods. Has been fixed on 2013-02-21. You might upgrade to
that Emacs version, when available from Debian.

Sorry for that.

> Alejandro

Best regards, Michael.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]