help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ffap-bindings incompatible with TRAMP?


From: Michael Albinus
Subject: Re: ffap-bindings incompatible with TRAMP?
Date: Wed, 25 Feb 2009 15:54:11 +0100
User-agent: Gnus/5.101 (Gnus v5.10.10) Emacs/21.3 (hpux)

Bernardo <address@hidden> writes:

>> TRAMP version 2.1.15
>> GNU/Linux Emacs 22.3.1

Are you sure Tramp 2.1.15 is loaded with your scenario? After starting
"emacs -Q" you need at least adapt the load-path. Emacs 22 comes with
Tramp 2.0.

> -------------------------------------------------
> the second scenario:
> a. start Emacs
>   $ emacs -Q &
>
> b. activate ffap-bindings
>   M-: (ffap-bindings)
>
> c. open /etc/hosts [1]
>   C-x C-f /su::/etc/hosts
>
> d. there is no prompt for root password although Emacs
>    was started from a user's account; the echo area says:
>    "Use M-x make-directory RET RET to create directory and its parents"
>    The /etc/hosts file isn't loaded.

I have done exactly as said with Emacs 23.0.90 / Tramp 2.1.15. The
only difference is that I have used "sudo" instead of "su" (because of
Ubuntu). I was prompted for the password, and it did run w/o any
problem.

Could you, please, repeat the test? Directly after starting Emacs, you
should apply "M-: (setq tramp-verbose 9)". If the problem happens,
please show the "*tramp/su address@hidden" and "*debug tramp/su address@hidden"
buffers.

> Regards, Bernardo

Best regards, Michael.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]