[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: keypad bindings in gnome not in xTerm ??

From: William Case
Subject: Re: keypad bindings in gnome not in xTerm ??
Date: Tue, 19 Aug 2008 10:09:18 -0400

Hi Kevin;

On Tue, 2008-08-19 at 02:29 -0600, Kevin Rodgers wrote:
> William Case wrote:
> > Hi Kevin;
> > 
> > On Fri, 2008-08-15 at 05:16 -0600, Kevin Rodgers wrote:
> >> William Case wrote:
> >>> I have some basic commands such 'kill-this-buffer' bound to keypad keys
> >>> e.g. <kp-subtract>.  As long as I am in a Gnome desktop it works fine.
> >>> If I switch to an xterm (C-A-Fx), the binding no longer works even
> >>> though C-h w says that 'kill-this-buffer' is still bound to
> >>> <kp-subtract>.  I have double checked that Num Lock is off.
> >>>
> >>> How can I get my keypad bindings to work in xTerminals?  They are what I
> >>> am used to now.
> >> What does `C-h k <kp-subtract>' show in xterm?
> > 
> > "self-insert-command"
> Ah, I see the same thing: - runs the command self-insert-command
> Note the absence of "(translated from <kp-subtract>)", which means
> that the terminal sent "-" to Emacs rather than an escape sequence.
> You can confirm that with `<kp-subtract> C-h l'.
I will chase this down.

> So I think you are out of luck and cannot bind <kp-subtract>
> independently of "-" in xterm.  But a little bit of Googling
> suggests that you might be able to get xterm to send escape
> sequences via X resources; then Emacs should automatically
> recognize <kp-subtract> via function-key-map.
> Please let us know if you figure out how to get xterm to
> send escape sequences for the keypad.

I will, but it is not just the keypad that is the problem.

Kevin, are you running Gnome and/or Fedora?  Why I ask is, this morning
I ran a little program to clean gconf and it came up with about 15
mis-configured keyboard conf-keys. (Not my doing that I know of.)  I
have other gnome problems creeping in as well.   It could be the result
of a fresh install while retaining my '/home' partition.  That's my
problem for another list and another day.

I just wondered if you were getting the same result because of the same
kind of problem.  I know emacs keeps itself pretty well divorced from
such things but one never knows what the distribution or desktop might
be forcing on the whole system in its latest incantation.

By the way, <kp-subtract> isn't the only binding I have lost.  I just
used that as an example.  Some others are straight forward like C-F1 =>
(find-file-other-window "/path/to/.emacs"). Several like that aren't
working either.  The mystery is that other custom .emacs commands are
working in xterm, just not the key bindings.

Regards Bill;
Fedora 9, Gnome 2.22.3
Evo., Emacs 22.2.1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]