[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

.emacs read but ignored

From: xjm
Subject: .emacs read but ignored
Date: Thu, 3 Jul 2008 12:21:02 -0700 (PDT)

I am hoping someone might be able to help me with an emacs issue that has me
quite frustrated.  My init file in my home directory on a dev webserver is
being ignored somehow.  The file appears to be read when I start emacs--if I
put non-interpretable garbage at the top of the file, emacs flashes an error
with the offending line when I start it--but all the settings in the .emacs
file seem to be disregarded.  E.g., I have:
(setq default-tab-width 2)
Even with this setting, I still get monstrous 8-character tabs.

I know it is not a problem with my .emacs file itself, because I am using a
copy of the exact same file on our live webserver with no problems.

OS: Gentoo
emacs 21.4.2
using bash

I found a similar, but slightly different, question in this list's archives:
The variables mentioned there seem correct for me (as below).
user-login-name: "myusername"
user-real-login-name: "myusername"
user-init-file: "/home/myusername/.emacs"
init-file-user: ""  (empty)

I've tried everything I can think of to get around the problem.  None of the
following have had an effect:
emacs -u myusername
emacs --load /home/myusername/.emacs
emacs --debug-init

I do not have root or any sort of administrative access on this server, but
my admin is a bit of a novice, so I want to have concrete instructions for
him if I have to get him to change something.

Thanks in advance for any advice or suggestions.
View this message in context:
Sent from the Emacs - Help mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]