help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NTEmacs + plink


From: Michael Albinus
Subject: Re: NTEmacs + plink
Date: Wed, 13 Jun 2007 12:50:16 +0200
User-agent: Gnus/5.1008 (Gnus v5.10.8) Emacs/21.3 (hpux)

address@hidden writes:

> However, I still cannot figure out multi hop. Using 
> /multi:plink:address@hidden:address@hidden:/home/me/realfile.txt
> gets as far as 
> Tramp:  Found remote shell prompt on `plink' 
> and then hangs emacs hard-- the window does not redraw in Windows and I 
> must kill the process from task manager. 

That is Tramp 2.0 style.

> Adding 
> (add-to-list 'tramp-default-proxies-alist
>            '("host\\.org#3322" nil "/plink:address@hidden:"))
>
> (with or without the port numbers) to _emacs causes 
> /plink:address@hidden:/home/me/realfile.txt
> to get as far as 
> Tramp: Opening connection for address@hidden using plink
> before hanging emacs in a similar way (waited more than 6 minutes to 
> be sure).

That is Tramp 2.1.

Which Tramp version are you using? I thought 2.1.9?

> I have the following in _emacs, and the startup sequence echoes the load
> command, so it is being read:
>
> (add-to-list 'load-path "C:/tramp/lisp")
> (load "C:/tramp/lisp/tramp.el")
> (setq tramp-default-method "plink")
>
> (nconc (cadr (assq 'tramp-login-args (assoc "plink" tramp-methods)))
>        '(("bash" "-i")))
>        (setcdr (assq 'tramp-remote-sh (assoc "plink" tramp-methods))
>               '("bash -i"))

I don't know whether it is a good idea to set bash. Why do you need it?

>       (setq tramp-debug-buffer t)
>       (setq tramp-verbose 10)

That's good. In the debug buffer, you might see what Tramp is
doing. Al the chatting with the remote host. Did you check it?
Otherwise, you could send the debug buffer for more investigations.

> tram-bug reports this:
> Emacs  : GNU Emacs 22.1.1 (i386-mingw-nt5.1.2600)
>  of 2007-06-02 on RELEASE
>  Package: tramp (2.0.55)
>  but the files in C:/tramp are 2.1.9

I have the strong feeling that you have installed Tramp without
calling ./configure ...

> On Gentoo, using a suitably modified equivalent .emacs file, I first get
> an error that trampver could not be loaded. In fact, this was not
> created until I ran ./configure. Then I got the error 

Same as above. ./configure is a must.

> Symbol's value as variable is void: tramp-gw-tunnel-method
> this is true on OSX emacs 22.0.52.1 as well as Gentoo x86 Emacs 21.4.1.

Yes, gateway methods work (as of today) only with Emacs 22.1. I didn't
hide the respective variables properly, fixed in CVS meanwhile. But
this is hopefully a warning only?

Best regards, Michael.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]