help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NTEmacs + plink


From: poti
Subject: Re: NTEmacs + plink
Date: Tue, 12 Jun 2007 19:44:31 -0400
User-agent: Mutt/1.5.13 (2006-08-11)

On 21:58 Tue 12 Jun     , Michael Albinus wrote:
> address@hidden writes:
> 
> > I have many difficulties with tramp. I use a non-standard ssh port and
> > have hosts behind firewalls. From Windows something like
> > /ssh:address@hidden:/home/me/.emacs or
> 
> That shall work, better even with plink.
> 
> Passing firewalls depend on how you want to do it. Tramp 2.1 (not part
> of Emacs 22.1) has introduced gateway methods, which are intented for
> HTTP tunnels or socks servers. But you could also configure HTTP tunnels
> directly in PuTTY, I guess.
> 
> If it is something else, just tell me the kind of hops you need. We
> could find the corresponding Tramp configuration then.
>
The line you quoted does in fact work from Windows. I did not have
.emacs in that particular directory, causing some confusion. 

I have sent what appears to be a tramp specific problem in opening a remote
directory to tramp-devel. Other than that, single hop seems to work. 

However, I still cannot figure out multi hop. Using 
/multi:plink:address@hidden:address@hidden:/home/me/realfile.txt
gets as far as 
Tramp:  Found remote shell prompt on `plink' 
and then hangs emacs hard-- the window does not redraw in Windows and I 
must kill the process from task manager. 

Adding 
(add-to-list 'tramp-default-proxies-alist
             '("host\\.org#3322" nil "/plink:address@hidden:"))

(with or without the port numbers) to _emacs causes 
/plink:address@hidden:/home/me/realfile.txt
to get as far as 
Tramp: Opening connection for address@hidden using plink
before hanging emacs in a similar way (waited more than 6 minutes to 
be sure).
One difference is that in this crash, EMACS.EXE is taking 50% of cpu
time, whereas in the previous it was idle and taking about 2K more
memory. 

As my network is configured at the moment, the only service available is
ssh. I can exchange keys between my.host.org and host.org, but not from
the lab XP machines to anywhere else.

I have the following in _emacs, and the startup sequence echoes the load
command, so it is being read:

(add-to-list 'load-path "C:/tramp/lisp")
(load "C:/tramp/lisp/tramp.el")
(setq tramp-default-method "plink")

(nconc (cadr (assq 'tramp-login-args (assoc "plink" tramp-methods)))
       '(("bash" "-i")))
       (setcdr (assq 'tramp-remote-sh (assoc "plink" tramp-methods))
        '("bash -i"))

        (setq tramp-debug-buffer t)
        (setq tramp-verbose 10)
tram-bug reports this:
Emacs  : GNU Emacs 22.1.1 (i386-mingw-nt5.1.2600)
 of 2007-06-02 on RELEASE
 Package: tramp (2.0.55)
 but the files in C:/tramp are 2.1.9

On Gentoo, using a suitably modified equivalent .emacs file, I first get
an error that trampver could not be loaded. In fact, this was not
created until I ran ./configure. Then I got the error 
Symbol's value as variable is void: tramp-gw-tunnel-method
this is true on OSX emacs 22.0.52.1 as well as Gentoo x86 Emacs 21.4.1.
make fails on OSX. On another Gentoo machine with Emacs 22.1 and
tramp-2.1.9-r1 installed through the package manager, I have many 
many more apparently unrelated problems. 

I also tried this with a cross port of tramp to Windows using mingw32 
and my x86 Gentoo machine, but still failed in the same way.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]