help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w3m gives 'Wrong type argument: stringp, nil" error


From: Christopher M. Balz
Subject: Re: w3m gives 'Wrong type argument: stringp, nil" error
Date: 4 Jun 2003 21:19:20 -0700

Well I did find those build instructions and now w3m v0.4.1 runs great
from a plain Cygwin shell. But, I noticed that while w3m_el-1.2.8
claims to run with the latest w3m, it actually needs w3m v0.3 (see
below).

I am still getting the same error as before, although I can see
relevant packages loading when on a fresh run of Emacs I enter
w3m-browse-url.  I doubt that a basic command line parameter would
change from 0.3 to 0.4.1, but it seems that some kind of argument to a
function is amiss.

It would be great to be able to browse Javadoc and other HTML doc with
a web browser inside Emacs!  Do you think that the problem is the
mismatch between w3m_el and w3m?

>From README at c:/Program Files/emacs/site/w3m_el-1.2.8/  ->

4. Version of w3m

   Because this program is sensitive to version of w3m, the latest
   version of w3m should be used.  Its latest official version is 0.3,
   which is released at March 6th, 2002.  Its source can be downloaded
   from:

      http://prdownloads.sourceforge.net/w3m/w3m-0.3.tar.gz



Kevin Rodgers <address@hidden> wrote in message news:<address@hidden>...
> [Please don't top-post: ]
> 
> Christopher M. Balz wrote:
> 
> > Do you know where to find English instructions for compiling w3m?
> 
> Well, the README file in the source distribution says:
> 
>       If you can read English, see doc/*.
> 
> And sure enough, the doc/README file has a section on Installation that refers
> Windows users to the doc/README.cygwin file (attached).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]