[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: multiple language dvi generation

From: Petr Šimon
Subject: Re: multiple language dvi generation
Date: Thu, 01 May 2003 22:10:43 +0800
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030212 Debian/1.2.1-9woody1

When I type my text (many different languages with different
encodings) I have to edit it with latex commands like
"\begin{document}" and so on, am I right?

This seems to be a TeX problem, and less an Emacs problem.
Apparently, you can enter your text using Emacs.  Your problem is
what text you need so that LaTeX groks it.

There are multilingual extensions for TeX (called Omega? Lambda?)
that, I think, accept UTF-8 as input.  I tried to use that once, but
I thoroughly failed because I'm a very bad TeXnician.

(What does the Chinese in your message mean, btw?)

Thanks a lot. Sometimes I need to kick to start to think ;-) One problem still remains. I don't use omega now, it should do without it. There is a package called cjk-latex which should do the job. But, I still get this nasty output and no dvi for chinese:

mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input gbsn05
This is METAFONT, Version 2.7182 (Web2C 7.4.5)

kpathsea: Running mktexmf gbsn05
! I can't find file `gbsn05'.
<*> ...:=ljfour; mag:=1; nonstopmode; input gbsn05

Please type another input file name
! Emergency stop.
<*> ...:=ljfour; mag:=1; nonstopmode; input gbsn05

Transcript written on mfput.log.
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input gbsn05' failed.
kpathsea: Appending font creation commands to missfont.log.

! Font C10/song/m/n/12/05=gbsn05 at 12.0pt not loadable: Metric (TFM) file not
<to be read again>
l.26 ^^e4^^b8^^ad^^e5

I understand that it can't find my fonts (am I right?), but I am sure that I have fonts installed. Can I explicitly set the path or what else I can do?
I tried another font with different encoding and I got another error:

! Argument of address@hidden has an extra }.
<inserted text>
l.26 ^^e4^^b8^^ad^^e5^^9c^^8b

What does it all mean? How do I fix it?
Thanks a lot
(the Chinese text meant: I DON'T KNOW ;-))

reply via email to

[Prev in Thread] Current Thread [Next in Thread]