help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: installing php-mode-102"


From: Peter S Galbraith
Subject: Re: installing php-mode-102"
Date: Fri, 02 Aug 2002 10:06:03 -0400

After the steps below, doing

 M-: (featurep 'php-mode)

should return 't, otherwise it's not properly loaded.

BTW, I downloaded the file and it won't load under emacs21.  You should
probably ask the authors of that file for help.


Scott <address@hidden> wrote:

> Alex-
> 
> I am new to emacs, been wanting to use it for about 2 years.  I am
> using the php-mode-102 file as well.
> 
> I have these lines in my .emacs file in my home dir.
> 
> (add-hook 'html-mode-hook 'turn-on-font-lock)
> (autoload 'html-helper-mode "html-helper-mode" "Yat HTML" t)
> (load-library "php-mode-102")
> (add-hook 'php-mode-user-hook 'turn-on-font-lock)
> 
> and the .el file in /usr/share/emacs/site-lisp
> 
> I am using Mandrake, your distro might vary.
> 
> -Scott
> 
> At 07:49 PM 8/1/2002 +0200, Alex Curvers wrote:
> >hello i am trying to install the php mode for emacs
> >i have put the .el file in the site-lisp dir
> >and added the lines :
> >
> >(load-library "php-mode-102")
> >(add-hook 'php-mode-user-hook 'turn-on-font-lock)
> >
> >to
> >/usr/share/themes/thEmacs/emacs/.emacs       (add the top)
> >but still i dont see any colorcoding for the php syntax,
> >
> >what am i doing wrong ?
> >
> >Regards Alex
> >
> >
> >
> >_______________________________________________
> >Help-gnu-emacs mailing list
> >address@hidden
> >http://mail.gnu.org/mailman/listinfo/help-gnu-emacs
> 
> 
> _______________________________________________
> Help-gnu-emacs mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/help-gnu-emacs



reply via email to

[Prev in Thread] Current Thread [Next in Thread]