[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Etags (different results from cmd or from emacs)

From: Eli Zaretskii
Subject: Re: [h-e-w] Etags (different results from cmd or from emacs)
Date: Fri, 27 Jun 2008 12:05:48 +0300

> Date: Thu, 26 Jun 2008 14:23:38 -0400
> From: "Andrei Stebakov" <address@hidden>
> I've been lately having problems with running cygwin's find.exe and etags
> from Emacs (Emacs-23-CvsP080612-EmacsW32-1.58.exe installer)
> When I use igrep-find (which uses cygwin's find.exe) from emacs, it takes
> much longer and returns partial results or no results at all so I need to
> run the same command again.

Does this happen if you use natively-compiled binaries of find.exe?

> With etags, if I run this command from cmd:
> "find.exe . -iname '*.cpp' -o -iname '*.h' -o -iname '*.c' | xargs etags"
> It create tags file of approximately 9MB and I can see all tags are there.
> If I run it from emacs:
> (shell-command "find.exe . -iname '*.cpp' -o -iname '*.h' -o -iname '*.c' |
> xargs etags")
> The size of resulting tags file is ~4MB and it misses tags.

What shell is used when you run shell-command?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]