[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Etags (different results from cmd or from emacs)

From: Lennart Borgman (gmail)
Subject: Re: [h-e-w] Etags (different results from cmd or from emacs)
Date: Fri, 27 Jun 2008 01:36:23 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20071031 Thunderbird/ Mnenhy/

Andrei Stebakov wrote:

I've been lately having problems with running cygwin's find.exe and etags from Emacs (Emacs-23-CvsP080612-EmacsW32-1.58.exe installer) When I use igrep-find (which uses cygwin's find.exe) from emacs, it takes much longer and returns partial results or no results at all so I need to run the same command again.
With etags, if I run this command from cmd:
"find.exe . -iname '*.cpp' -o -iname '*.h' -o -iname '*.c' | xargs etags"
It create tags file of approximately 9MB and I can see all tags are there.
If I run it from emacs:
(shell-command "find.exe . -iname '*.cpp' -o -iname '*.h' -o -iname '*.c' | xargs etags")
The size of resulting tags file is ~4MB and it misses tags.

I wonder how these problems can be fixed?
Thank you,

It looks like a possible bug. Please follow the bug reporting instructions. Note that you need to install the unpatched version to report bugs of this kind.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]