[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health-dev] Issue on install

From: Marc Murray
Subject: Re: [Health-dev] Issue on install
Date: Tue, 05 Apr 2016 18:23:46 -0500

On Tue, 2016-04-05 at 16:07 -0500, Carlos Eduardo Sotelo Pinto wrote:

I have been installing the last one version and I have gotten a pip error, I have solved it comenting the line refered a vbobject and installing it on my side, some one have the same error?

best regards

==> default: [13:59:44] >> psycopg2==2.6.1
==> default: Requirement already up-to-date: psycopg2==2.6.1 in /home/vagrant/.local/lib/python2.7/site-packages
==> default: [13:59:45] >> OK
==> default:
==> default: [13:59:45] >> vobject==0.8.1c
==> default: Collecting vobject==0.8.1c
==> default:   Using cached
==> default:     Complete output from command python egg_info:
==> default:     Traceback (most recent call last):
==> default:       File "<string>", line 1, in <module>
==> default:     IOError: [Errno 2] No such file or directory: '/tmp/pip-build-d8a8p9/vobject/'

Because vobject has the "c" in its version string, pip treats it as an RC package, not yet released. I often get an error saying that pip can't find a suitable version of vobject>=0.8.1

The solution, I have found, is to pass the --pre switch to pip install. This will tell pip that you're willing to install pre-release/beta versioned packages (like vobject 0.8.1c).

pip install --pre 'vobject==0.8.1c'

I hope this helps.


Carlos Eduardo Sotelo Pinto
    Senior Software Analyst Developer
    Claro RPC +51983265994 | MOV RPM( # ) +51 966110066
    GTalk: address@hidden | Skype: csotelop
    GNULinux RU #379182 | GNULinux RM #277661

No availability between 08:30 and 18:00, I will answer as soon as posible

Please consider the environment before printing this email
Join the campaign at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]