[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GWhere-discussion] gwhere installation

From: WL
Subject: Re: [GWhere-discussion] gwhere installation
Date: Sat, 13 Aug 2011 17:09:18 +0200
User-agent: Opera Mail/11.50 (Linux)

Hi Davide,

On Thu, 11 Aug 2011 16:41:09 +0200, Davide Trevisan <address@hidden> wrote:
Hi everybody, this program was told me to be perfect for certain job(!).

Quite usable, for my needs, anyway.

But this is the problem : trying to install it from debian package I get
this error : 'Errore: La dipendenza non può essere soddisfatta:
libglib1.2 (>= 1.2.0)'

The gwhere version you try to install is too old, apparently.

but I have libglib2.0-0 installed on my Ubuntu

Me too.

10.04; isn't it an higher version ?

Yes, but possibly has different usage (API), as the higher first digit "2" implies.

Can I some way force the
installation by dpkg ? (I've used gdebi 0.6)

In principle yes, but it would still need a libglib1.x, so probably not workable.

The solution here is simply to use the gwhere 0.2.3 from Ubuntu repository. My box tells me:

$ apt-cache policy gwhere
  Installed: (none)
  Candidate: 0.2.3.dfsg.1-3
  Version table:
     0.2.3.dfsg.1-3 0
        500 lucid/universe Packages

So gwhere 0.2.3 appears to lie in the official universe repository, which has to be enabled in the Preferences' "Software sources".

Alternatively, you could get it from its homepage... or rather not, the .deb package version 1.6 there is quite old. So go with universe.

Then it could be as simple as

        apt-get install gwhere

which should fetch and install that v0.2.3.

.. I don't know, I'm not a very advanced linux user, of course.

Just keep at it, and your knowledge will grow just by getting used to it.

Thank so much for your answer

You're welcome.
-- Wolf Lichtenberger

reply via email to

[Prev in Thread] Current Thread [Next in Thread]