[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug#30469] [PATCH 0/1] Require Guile >= 2.0.14

From: Jonathan Brielmaier
Subject: [bug#30469] [PATCH 0/1] Require Guile >= 2.0.14
Date: Sun, 25 Feb 2018 12:53:29 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0

On 02/24/2018 11:41 PM, Ludovic Courtès wrote:>> How much of this patch
would change if it were to instead support
>> 2.0.13?  Is cutting off users of Debian stable a good idea?
> I’ll double-check but I think the patch remains valid if we require
> 2.0.13.

Opensuse Leap 15 will have 2.0.14, so I would be okay with it.

> If it works I’ll commit that next week.
>>> I’d also like it to be the last release that support Guile 2.0.
>> Same question.
> 2.2 is becoming quite widespread in distros.
> Overall it’s a cost/benefit tradeoff, and we have to take into account
> that most users get Guix using the binary tarball or GuixSD.

2.2 is not as easy as I thought it would be, to bring it to openSUSE
Leap. There are packages who still require guile 2.0 (see comments in And the fact that only
a handful of packages need guile, makes it not really worthwhile for
distros to have two versions of guile present like we see it for python.

It would be nice to have guix in Debian, Ubuntu, SUSE land and Red Hat
land. I think that would enable far more people to use guix.

At the moment it's not easy to install guix from source without having
guix in place, at least on openSUSE. You need those guile modules
(guile-git, guile-bytestructures) who comes with almost no build
documentation. And then you have to fiddle together guile with the right

We struggle a lot with bootstrapping rust, go, java etc, so we should
make sure that "bootstrapping" guix (install from source) is easy or at
least doable.

Best Regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]