[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug#30469] [PATCH 0/1] Require Guile >= 2.0.14

From: Ludovic Courtès
Subject: [bug#30469] [PATCH 0/1] Require Guile >= 2.0.14
Date: Tue, 27 Feb 2018 18:23:35 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)

Hi Jonathan,

Jonathan Brielmaier <address@hidden> skribis:

> 2.2 is not as easy as I thought it would be, to bring it to openSUSE
> Leap. There are packages who still require guile 2.0 (see comments in
> And the fact that only
> a handful of packages need guile, makes it not really worthwhile for
> distros to have two versions of guile present like we see it for python.
> It would be nice to have guix in Debian, Ubuntu, SUSE land and Red Hat
> land. I think that would enable far more people to use guix.
> At the moment it's not easy to install guix from source without having
> guix in place, at least on openSUSE. You need those guile modules
> (guile-git, guile-bytestructures) who comes with almost no build
> documentation. And then you have to fiddle together guile with the right
> versions...
> We struggle a lot with bootstrapping rust, go, java etc, so we should
> make sure that "bootstrapping" guix (install from source) is easy or at
> least doable.


It becomes clearer to me that we would want to take advantage of Guix’
modularity here so that one can build just the core of Guix with no
dependencies other than Guile and libgcrypt maybe, and from there build
higher-level layers, etc.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]