[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 can not detect usb disk

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: Grub2 can not detect usb disk
Date: Thu, 21 Jul 2011 13:11:10 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110626 Iceowl/1.0b2 Icedove/3.1.11

On 12.07.2011 13:11, Cui Lei wrote:
> Hi Vladimir, I have not received you reply for some days. I think you must be 
> very busy, so I did some works on my own way.
> I tested dozens of versions between r2249 and r3229. I found that most of 
> them can boot my machine with "--with-platform=multiboot" option rather than 
> "--with-platform=coreboot" option. The latest one I used is r3200, I think it 
> should 
> support usb device nicely. I added usb.mod uhci.mod usbms.mod usbtest.mod 
> into the image(payload.elf), but it can not detect
> my usb disk stilly. But if I plug a usb stick into my board after booting 
> into the grub shell( grub> ), I get these message:
> /*********************************************************************************/
>       grub> bus/usb/usbhub.c:208: total=250
>       bus/usb/usbtrans.c:93: control: reqtype=0x80 req=0x06 val=0x100 idx=0x00
>       size=8
>       bus/usb/usbtrans.c:120: control: transfer = 0x7fe4cec0, dev = 0x7fe36ea0
>       bus/usb/usbtrans.c:187: control: err=7
It looks like GRUB has seen the device but no real data was transfered.
Could you try with low-speed device? E.g. keyboard. I think you may need
ehci driver (Aleš recently coded one)
> /*******************************************************************************************************/
> I looked at the source code and found err7 is time out error, I don't
> know how to fix it.
> I need your help and anyone's advices. It is long time I have spended
> on this project. So look forward to your replay.
> Thank you in advance.
> BRs,
> Rock.
>> I have read the source code about the mmap of grub and of corebootV4,
>> I found that the size of their table header struct are not same, and
>> I think ,in the file "mmap.c" of grub2,on the 53rd line, the offset
>> of the first table item may be error.
>> BRs,
>> Rock.
>> At 2011-07-05 14:35:28,"Cui Lei" <address@hidden> wrote:
>>     I think the "skip=2146422784" is too big.
>>>       I received you reply this monday, then my office PC had a
>>>     problem ,can not power on, so I write you late.
>>>     I have tried to run "dd", but got "Reading a error address".
>>>>     On 01.07.2011 08:57, Rock Cui wrote:
>>>>>     Sorry,I am careless, my log file is not empty, please refer to the
>>>>>     attachment.
>>>>     I would also need another memory location for full diagnostics:
>>>>     sudo dd if=/dev/mem of=tables bs=1 count=65536 skip=2146422784
>>>>     Looking at the code, the only way it can hang AFAICT should be fixed by
>>>>     attached patch (mostly guessing)
>>>>>>     1. I have tried the "--with-platform=multiboot" option, but when
>>>>>>     booting it show me:
>>>>>>     /*********************/
>>>>>>     Welcome to GRUB!
>>>>>>     out of memory
>>>>>>     Aborted.
>>>>>>     /*********************/
>>>>>>     2. The /dev/mem you need , how can I get it? I want it should be from
>>>>>>     the "/" , then I must enter the ubuntu.
>>>>>>     So I use the grub1.98 as coreboot payload and boot my ubuntu11.04.
>>>>>>     But when I copy the /dev/mem to a log file with "sudo",
>>>>>>     I was told “You can not do it!” : (
>>>>>>>     On 30.06.2011 04:38, Cui Lei wrote:
>>>>>>>>     I have found the the last version which can boot my machine, it is
>>>>>>>>     the r2348. The r2349 can not boot it.
>>>>>>>>     So I checked out the changelog from 2348 to 2349 :
>>>>>>>     Ironically I did it because i386-coreboot didn't work in my tests.
>>>>>>>     Could
>>>>>>>     you send me the first 128K of /dev/mem ? Meanwhile you can try
>>>>>>>     i386-multiboot port.
>>>>>>>     _______________________________________________
>>>>>>>     Grub-devel mailing list
>>>>>>>     address@hidden
>>>>>>     _______________________________________________
>>>>>>     Grub-devel mailing list
>>>>>>     address@hidden
>>>>>     _______________________________________________
>>>>>     Grub-devel mailing list
>>>>>     address@hidden
>>>>     _______________________________________________
>>>>     Grub-devel mailing list
>>>>     address@hidden
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Vladimir 'φ-coder/phcoder' Serbinenko

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]