[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Groff] EPS importing problem

From: Ted Harding
Subject: [Groff] EPS importing problem
Date: Wed, 09 Sep 2009 16:05:10 +0100 (BST)

Hi Folks,
I'm encountering some problems importing an EPS file into a groff
document. This is part of an attempt to resolve difficulties
arising in the production of EPS graphics using the R statistical
software package, in particular the use of the function embedFonts().
For those who want to track it to source, the email thread on the
R-help mailing list starts at:

  [R] eps file with embedded font   Simone Gabbriellini

in the thread-based listing at

It has been partially solved (by Paul Murrel in that thread). What,
however, seems to remain is the issue of importing the file successfully
into a document. To test this, I used groff (of course ... ).

Attached are two EPS files:


The first was plain EPS output from a simple plot-test in R, and it
is nicely visible using 'gv' and also imports nicely into groff with
(using ms macros)

.PSPIC test1.eps 4i

The second, in its present form, is also nicely visible with 'gv'.

However, when I try to further include it into the document with

.PSPIC test1.eps 4i
.sp 2
.PSPIC test1-EMB2.eps 4i

the resulting PS file, when viewed in 'gv', gives a brief glimpse
of the (previously successfully imported) graphic from test1.eps,
as before, along with a brief glimps of the very top of the graphic
from test1-EMB2.eps at the bottom of the page, and in the wrong size.
Furthermore, the resulting PS file when printed on a PostScript
printer simply produces a blank sheet of paper.

When the groff command is run, there is a message:

  grops:test1-EMB2.eps:14: missing argument

whose source I cannot track down!

I don't have access to other software which can create documents
with imported EPS files. In particular I have not tried TeX (maybe
someone would be so kind as to try)! The OpenOffice oowriter does
not seem to accept EPS files in any case.

The R command embedFonts() generated the following ghostscript
command to create test1-EMB2.eps from test1.eps:

gs -dNOPAUSE -dBATCH -q -dAutoRotatePages=/None -sDEVICE=pswrite \
   -sOutputFile=/tmp/RtmpjFAoV4/Rembed74b0dc51 \
   -dDEVICEHEIGHTPOINTS=360 test1.eps

(the output temporarily stored in /tmp/RtmpjFAoV4/Rembed74b0dc51 ).

I would be grateful if anyone could
a) Try importing these two files into a groff document on the
   lines of [B] above, to see if they get a better result;
b) Try importing them both into a document using different software;
c) Come up with suggestions about what the prblem with the second
   EPS file might be!

With thanks,

E-Mail: (Ted Harding) <address@hidden>
Fax-to-email: +44 (0)870 094 0861
Date: 09-Sep-09                                       Time: 16:05:05
------------------------------ XFMail ------------------------------

Attachment: test1.eps
Description: test1.eps

Attachment: test1-EMB2.eps
Description: test1-EMB2.eps

reply via email to

[Prev in Thread] Current Thread [Next in Thread]