[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trouble with PPS on u-blox 7

From: Gary E. Miller
Subject: Re: Trouble with PPS on u-blox 7
Date: Fri, 22 Apr 2022 11:16:52 -0700


On Fri, 22 Apr 2022 11:50:49 -0400 wrote:

> I'm having trouble getting PPS from a u-blox 7 device.

Yeah, you will.  Those need an outdoor antenna with a good sky view.

You mention nothing of how your PPS is connected to your host.  As
a HAT, PCI, USB, RS-232?

You mention nothing of your host: PC, Raspberry Pi, Apple Mac, etc.
That, and the OD on it, matters.

since most people don't realize what info we need to help, run this
script, as root, and send back here the restuls:

> When I run gpsmon, the value for PPS is simply N/A. I've also tried 
> using ppscheck, which doesn't return any results.

I guess you did not read the Time Service HOWTO:

No point even starting gpsd until ppscheck works for you.

> I do get a good
> sync to six satellites.

I would hardly call 6 "good".  Do you have a 3D Fix?

> I get UBX-ACK-ACK when I try "ubxtool -e PPS" and/or "ubxtool -e
> TIM-TP" so it looks like the unit should support PPS. Additionally, I
> can see the device /dev/pps0 is created and lsmod shows both
> pps_ldisc and pps_core are loaded. It certainly appears that I should
> be getting PPS data.

Ma y fact not in evidence, see above.

> I'm running Debian Buster with stock kernel 4.19.0-20-686-pae on x86 
> hardware.

4.19?  Really?  Ouch.

But more important, what version gpsd, etc.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can't measure it, you can't improve it." - Lord Kelvin

Attachment: pgpkQxRDvaTi_.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]