[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trouble with PPS on u-blox 7

From: gpsd
Subject: Trouble with PPS on u-blox 7
Date: Fri, 22 Apr 2022 11:50:49 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.7.0


I'm having trouble getting PPS from a u-blox 7 device.

I've got a USB receiver that's based on the u-blox 7. A "ubxtool -p MON-VER" reports:

  swVersion 1.00 (59842)
  hwVersion 00070000
  extension PROTVER 14.00
  extension GPS;SBAS;GLO;QZSS

When I run gpsmon, the value for PPS is simply N/A. I've also tried using ppscheck, which doesn't return any results. I do get a good sync to six satellites.

I get UBX-ACK-ACK when I try "ubxtool -e PPS" and/or "ubxtool -e TIM-TP" so it looks like the unit should support PPS. Additionally, I can see the device /dev/pps0 is created and lsmod shows both pps_ldisc and pps_core are loaded. It certainly appears that I should be getting PPS data.

I'm running Debian Buster with stock kernel 4.19.0-20-686-pae on x86 hardware.

Does anyone have any thoughts/suggestions?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]