[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Only one client at a time (Debian, Raspbian)

From: Gary E. Miller
Subject: Re: Only one client at a time (Debian, Raspbian)
Date: Thu, 29 Jul 2021 14:17:52 -0700

Yo Carles!

On Thu, 29 Jul 2021 22:58:20 +0200
Carles Pina i Estany <> wrote:

> Thanks for your answer - I'm new with gpsd - if I do "strange things"
> making my life difficult please let me know, I might not have
> discovered the easy way!

That problem is UNIX is too many choices.  :-)

> I have now:
> pi@raspberrypi:~ $ lsb_release -a
> No LSB modules are available.
> Distributor ID:       Raspbian
> Description:  Raspbian GNU/Linux 10 (buster)
> Release:      10
> Codename:     buster

I don't know what that is, and I don't care, too many distros to keep
in my head.

> pi@raspberrypi:~ $ gpsd -V
> gpsd: 3.20 (revision 3.20)

Almost 2 years old.  known CVE, and will fail on 23 October 2021.

> # Other options you want to pass to gpsd

"-n" is recommended there.

> Then I connect the eTrex, I answer "No" for the "USB Mass Storage".

Odd, then it sends NMEA?  What device does it show up as?  Clearly the
hotplug is finding it.

> And I get the NMEA strings doing "telnet 10110" (or
> localhost...) and in the file.

gpspipe could do that, in a lisghtly different manner.

> Quick question if you don't mind: off the top of your head: do you
> expect "Garmin GLO 2" device to work? I think that it's this one:

It says it does Bluetooth.  So it should work.  Except Bluetooth and
gpsd together are fragile.

> I'm new in all this world and I don't know how often things "just
> work" (like a USB memory stick, in a standard way) or if they are very
> specific to each device.

Total lack of standardization in the GPS/GNSS receiver market.  A mess.
Common devices work with gpsd because someone beats them into submission.

> > I can't speak to the Debian package,  that is not from us.  
> I updated gpsd Debian package to a newer version solved the problem
> that I had (but I might have new problems! - after 10 or 20 min it
> seems to sometimes just stop. I haven't done more testing yet).

Add the "-n" option.  That forces gpsd to stay alive.

> > New one on me.  Why use it?  
> Ideally I would like gpsd to get the positions from the eTrex 30x
> (whatever the on-wire protocol between gpsd and eTrex use) and then I
> would like gpsd to:
> -Save NMEAs to a file

$ gpspipe -r > nmea.log

> -Make NMEAs available over a TCP port

"-G" option makes gpsd available on port 2947.

> My understanding is that gpsd cannot do this.

Not mine.

> How could I do it without kplex?

gpspipe, and the "-G" option.  Not exactly the same thing.

> As far as I know qgis cannot connect to a port and read NMEA strings
> like OpenCPN can do (or like I do with "telnet IP PORT" and I just get
> it from kplex).

What qgis does is better than NMEA.

> OpenCPN has both: connect and read NMEA strings or do the gpsd client
> version. I was just discussing my setup in case that it was relevant.

NMEA is ill-defined.  gpsd JSON is better.

> > > As soon as one software (e.g. kplex) uses it, the other one (qgis)
> > > cannot use it.  
> > 
> > I often connect multiple clients over port 2947 with no problem.
> > For example: xgps, xgps and gpspipe all at the same time.
> > 
> > Can you connect two cgps?  Or one cgps and one xgps?  
> I could connect two cgps after upgrading gpsd to a newer version than
> what I had in Debian Buster (3.17 to 3.20)

So, problem solved.

> > 3.17 is ancient.  3.23 is to be releassed bext week.  
> with 3.20 it works fine... (different clients) for a while! After a
> while (10, 20 min) it stops working and I need to disconnect and
> connect the GPS. Still using systemd.

Try the "-n".

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can't measure it, you can't improve it." - Lord Kelvin

Attachment: pgptRCKrnmYGG.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]