[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ubxtool configuration

From: Florian Kiera
Subject: Re: ubxtool configuration
Date: Tue, 26 May 2020 09:05:30 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.8.1

Hey Gary!

Am 25.05.20 um 19:49 schrieb Gary E. Miller:
Yo Florian!

On Mon, 25 May 2020 16:50:43 +0200
Florian Kiera <address@hidden> wrote:

I want to configure the rover and base M8P with ubxtool now. On my
rover's computer I run "gpsd -n /dev/ttyACM0 -G
ntrip://root:root@ -N" to receive correction
data (RTCM3).

How can I address /dev/ttyACM0 with ubxtool (to configure it)?
Directions are on the man page.  Two ways:

1. configure before you start gpsd

2. since gpsd has two sources, you need to tell it which source to
attach to:
         ubxtool ::/dev/ttyACM0
Thank you, exactly what I was looking for!
Just using "ubxtool -p CONFIG" will end up with
"{"class":"ERROR","message":"No path specified in DEVICE, but
multiple devices are attached."}"
Yup.  Just as it says.  You need to specify which source, as above.

Using "ubxtool -f /dev/ttyACM0 -p RESET" will end up with:
That is because -f is reaonly, used for capture files.

Thank you! Thought files were set to read-only and ports were read/write, so guess not. ::device solved it.

Regards Florian

reply via email to

[Prev in Thread] Current Thread [Next in Thread]