[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Segfault after upgrade.

From: Paul Theodoropoulos
Subject: Re: Segfault after upgrade.
Date: Mon, 25 May 2020 12:20:51 -0700
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.8.0

On 5/25/2020 8:25 AM, David J Taylor wrote:
I tried the github approach, and I was surprised that it worked relatively easily (much more so that some other software I've compiled).  It takes almost half an hour to install the support software and compile, though. This is a single-core "smartphone" chip with just 512 MB of memory after all!  I hadn't found these instructions until a Google search:

I'm having trouble getting gpsd to auto-start, but that can wait for another day.  ubxtool works as expected to add Galileo to the default MAX-M8Q configuration.

systemctl status gpsd.service
If it reports
Unit gpsd.service could not be found.
then check in /etc/systemd/system for a gpsd.service file. if there's not one there, there is an example one in the repository at ./systemd/gpsd.service.

copy that to /etc/systemd/system, edit as desired, then run
systemctl enable gpsd
systemctl start gpsd
systemctl status gpsd
That should give you something approximating:
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/etc/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (exited) since Tue 2020-04-21 16:29:44 PDT; 1 months 3 days ago
 Main PID: 5157 (code=exited, status=0/SUCCESS)
   Memory: 1.4M
      CPU: 1h 21min 49.209s
   CGroup: /system.slice/gpsd.service
           └─5158 /usr/local/sbin/gpsd -n -r -P /run/ /dev/gpsd0

Paul Theodoropoulos

reply via email to

[Prev in Thread] Current Thread [Next in Thread]