[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Illegal instruction....

From: David J Taylor
Subject: Re: Illegal instruction....
Date: Mon, 25 May 2020 18:51:49 +0100

-----Original Message----- From: Martin Burnicki
Sent: Monday, May 25, 2020 5:19 PM
To: address@hidden
Subject: Re: Illegal instruction....

David J Taylor wrote:
Having now got gpsd 3.20 installed and working on my Raspberry Pi 1B
(with thanks to Gary and several others for their help) I thought I
would be ably simply to compile and run my monitoring software:

However, although the program compiles and runs on a Raspberry Pi 4B, on
the Raspberry Pi 1B it just says "Illegal instruction".

"Illegal instruction" sounds like the compiled machine code contains
instructions that are not appropriate for the CPU.

For example, if you had compiled a program on a PC with Pentium
processor and tried to run it on an old 386, that might happen, too,
even though both are 32 bit. The reason is because the Pentium knows
some newer CPU instructions that a 386 didn't know.

I think the same could happen on a Raspi if you compiled a program on a
newer 32 bit Raspi and and tried to run it on another one with an older CPU.

Have you also *built* gpsd on the Raspi 1B, or have you just copied the
executable program from the Raspi 4B to the Raspi 1B?

You could run the 'file' command that was mentioned before on the old
Raspi. Compare the output of

 file gpsd

to the output of

 file /usr/bin/zip

or any other file in /usr/bin/ that has come with the distro. Maybe just
post the output here.

We still don't
know /why/ there was problem with 3.20 from the backports not working,
but I'd wondered about the ARM level.  I tried a number of ARM versions
but still got the illegal instruction.

Inexperienced as I am, I don't know how to proceed, or what the issue is
likely to be.  cgps and ubxtool both work exactly as expected.

I thing the processor type has to match *exactly*, and the best way to
achieve this is to build a program on the target system.



Thanks for your thoughts.

Yes, it's all built from the same source, and on the target system. A build takes about 30 minutes. The gpsd, cgps and ubxtool all work correctly. Nothing should have come from the distro and made sure to delete the distro versions. It's a good question where the headers came from, though. I need to work through that tomorrow.

The only CPU differences I'm aware of are number of cores and ARM level.

I'll check further tomorrow.

SatSignal Software - Quality software for you
Email: address@hidden
Twitter: @gm8arv

reply via email to

[Prev in Thread] Current Thread [Next in Thread]