[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] pps on rpi

From: Wolfgang S Rupprecht
Subject: Re: [gpsd-users] pps on rpi
Date: Sun, 05 Mar 2017 12:04:17 -0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

"Gary E. Miller" <address@hidden> writes:
Yo Gary!  Long time...

> I you are using TIOMCIWAIT on a RasPi you kernel is configured
> wrong.  You should be using KPPS.

I was having a dickens of a time with scons caching things as a slowly
pieced together all the apt-gets I needed.  I thought I solved it by
doing an "rm -f .sconsign.dblite" in my build script.

> Have you read the howto?

I don't believe I've seen that one.  Thanks!  That is far superior to
the dozens of howto pages google found for me.

On recommendation of that howto I switched from compiling with a
straight "scons" to:
"scons timeservice=yes magic_hat=yes nmea0183=yes fixed_port_speed=9600 

Gpsd no longer complains about TIOMCIWAIT.   All it not happy though.

There is a perms problem.  pps0 is root.root owned and 660.  Gpsd can't
open it.

After changing it to 666 as a test gpsd can open it but complains that
someone else has it open.  (which is correct)

I run the brand-C ntp daemon (sorry, don't want to hurt anyone's
feelings here).  It opens /dev/pps0 itself in the way I have it
configured.  I had thought that pps0 would duplicate the output to all
listeners but perhaps not.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]