[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] pps on rpi

From: Gary E. Miller
Subject: Re: [gpsd-users] pps on rpi
Date: Mon, 6 Mar 2017 14:06:19 -0800

Yo Wolfgang!

On Sun, 05 Mar 2017 12:04:17 -0800
Wolfgang S Rupprecht <address@hidden> wrote:

> "Gary E. Miller" <address@hidden> writes:
> Yo Gary!  Long time...
> > I you are using TIOMCIWAIT on a RasPi you kernel is configured
> > wrong.  You should be using KPPS.  
> I was having a dickens of a time with scons caching things as a slowly
> pieced together all the apt-gets I needed.  I thought I solved it by
> doing an "rm -f .sconsign.dblite" in my build script.

I hear you.  I just often do a new 'git clone'.

> There is a perms problem.  pps0 is root.root owned and 660.  Gpsd
> can't open it.

Since gpsd runs as root, why not?

> After changing it to 666 as a test gpsd can open it but complains that
> someone else has it open.  (which is correct)

Hmm, I do not know if two readers on pps0 is a problem or not?

> I run the brand-C ntp daemon (sorry, don't want to hurt anyone's
> feelings here).  It opens /dev/pps0 itself in the way I have it
> configured.  I had thought that pps0 would duplicate the output to all
> listeners but perhaps not.

I'm unclear why you would program NTPClassic or NTPsec to open pps0 
when you are using pps0.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can’t measure it, you can’t improve it." - Lord Kelvin

Attachment: pgpthljAsd3PX.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]