[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] forcing baud and protocol

From: Roger Oberholtzer
Subject: Re: [gpsd-users] forcing baud and protocol
Date: Tue, 15 Nov 2016 11:25:03 +0000

We use high-end receivers via a serial port and had the same baud rate issue. 
The only thing we found that worked was making a udev rule:

KERNEL=="ttyS1",  SYMLINK="gps", MODE="666", OPTIONS="last_rule", 
RUN+="/usr/bin/stty -F /dev/gps 38400"

We set the baud rate that the receiver has in the RUN part. We found that when 
gpsd looks for the baud rate, it seems to try whatever the serial port is set 
to first, and only if that fails does it explore. The other options in the rule 
are for our own use. It is the RUN part that is the key.

Roger Oberholtzer

RST Systems

Office: +46 (0)10-615 6020
Mobile: +46 (0)70-815 1696

Ramböll Sverige AB
Krukmakargatan 21
P.O. Box 17009
SE-104 62 Stockholm, Sweden

From: gpsd-users address@hidden on behalf of S. Franks address@hidden
Sent: Tuesday, November 15, 2016 1:05 AM
To: address@hidden
Subject: [gpsd-users] forcing baud and protocol

We've built gpsd with open-embedded/yocto for our Toradex / NXP imx6
arm twice this year.

One experience was with a trimble Resolution T (TSIP) GPS.

Other was a custom $6000 RTK device which outputs clean NMEA 0183:

Both GPS are putting out an exemplary protocol stream, all my code can
decode time and LLA from either.

gpsd sees nothing.

We can connect any program (ie foxtrot) and LLA is always zero.

We see gpsd go through all the protocols, says no match for all of them.

I know what protocols I need to digest, and I know what the baud rate is.

I need to force them. This apparently is really helpful for people in
their basement with a $50 star-whatever from ebay.

But it looks to break badly when using an expensive GPS...

We've tried every possible combination of -b and -N and -n with no luck.

"It just (doesn't) works."


reply via email to

[Prev in Thread] Current Thread [Next in Thread]