[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-users] gpsd not capturing device on startup

From: Joshua Quesenberry
Subject: [gpsd-users] gpsd not capturing device on startup
Date: Tue, 15 Nov 2016 09:54:10 -0500



1.       I’m having some issues with gpsd on startup. I’m putting my device in the DEVICES variable in /etc/default/gpsd however after a restart, even though I see through ps aux that the DEVICES variable is included in the run string, when I run my test application to read from shared memory it’s reporting all values as zero (0). Only after killing gpsd and re-running it manually do I get data in shared memory. What am I missing?


2.       Is there a way to view list of attached devices and what driver is being used for that device? I know there are things like cgps and gpspipe, but it seems that those may do something extra in the background to force thing to work, things not being done when I simply open shared memory or start gpsd manually. So just looking for non-gps-interactive gpsd status command or something.


3.       Whenever I set START_DAEMON and USBAUTO to false I notice that gpsd will still be running after a reboot. Should this not prevent autostart?


4.       Whenever I run the commands systemctl disable gpsd.service, systemctl disable gpsd.socket, and systemctl disable address@hidden I continue to see gpsd getting started after a reboot, I was only able to stop the starting by moving the files out of /lib/system/system entirely. Should these commands not prevent the systemd services from running?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]