[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] Support for PPS on 10Hz Devices

From: Andrew Yong
Subject: Re: [gpsd-users] Support for PPS on 10Hz Devices
Date: Thu, 3 Oct 2013 02:59:37 +0800

Hi Gary and other GPSD users,

I’ve left my gpsd running spitting out debug | grep ntpshm for a while; GPSD is accepting the PPS leading edge consistently every second, however I still get this after running GPSD for about an hour:

gpsd:RAW: NTPD ntpshm_put: Clock: 1380740261.000000 @ 1380740261.113936, fudge: 0.000
gpsd:RAW: PPS ntpshm_pps: no current GPS seconds: -1380740261113936
gpsd:RAW: NTPD ntpshm_put: Clock: 1380740262.000000 @ 1380740262.124404, fudge: 0.000
gpsd:RAW: PPS ntpshm_pps: no current GPS seconds: -1380740262124404
gpsd:RAW: NTPD ntpshm_put: Clock: 1380740263.000000 @ 1380740263.172770, fudge: 0.000
gpsd:RAW: PPS ntpshm_pps: no current GPS seconds: -1380740263172770
gpsd:RAW: NTPD ntpshm_put: Clock: 1380740264.000000 @ 1380740264.192086, fudge: 0.000

Any idea why this may be? NMEA is coming in at 1Hz.

On Mon, Sep 16, 2013 at 2:55 PM, Gary E. Miller <address@hidden> wrote:
Yo Andrew!

On Mon, 16 Sep 2013 13:01:37 +0800
Andrew Yong <address@hidden> wrote:

> >> Yep, the PPS still comes in at 1Hz, but for some reason GPSD
> >> doesn't pick it up.
> >
> > How do you know it is coming if you can't see it?  What RS-232
> > pin is it coming in on?  Have you tried high debugging levels in
> > gpsd to see hat gpsd is seeing?
> I ran it at 10 and grepped for PPS|NTP. Nothing of note is output at
> 10Hz. Same module at 1Hz NMEA has PPS detected.

What is the GPS module.  I'll try to find documentation for it.

So gpsd is working fine with PPS for you at 1Hz updates, but not at
10Hz updates, all else being equal?  And you see gpsd PPS debug output
at 1Hz but none at 10Hz?

Unless you are on a rocket the 10Hz is no better than 1Hz.  Any reason
not to just run at 1H.

> I have it on a USB FTDI chip’s DCD pin. I see DCD blinking at 1Hz
> using RealTerm on Windows, regardless of 1/5/10Hz NMEA updates.

Can you get an osciloscope on the pin and see what it is doing?

> Pretty sure it's picking up PPS correctly at 1Hz as my PPS LED and
> GPSD debug output coincide perfectly.

Have you fed ntpd from gpsd, that will tell you if your PPS is really good.

> > gpsd can handle everything from a pulse so small the UART does not
> > see both edges to a 2HZ square wave where each edge is on the
> > second.  100 milli Sec is good because there is no ambiguity on
> > which edge, but 1 milli Sec to 200 milli Sec would be equally
> > good.  Just let it be.
> That's good to know. At 1Hz it picks both edges and always chooses
> the rising edge. So I'm going to say it works as intended.

Rising is sort of relative.  What it is picking up is the edge after
the long part of the rectangular waveform, then ignoring the edge after
the short part.  So any inverters have no affect.

> However it rejects the PPS because of a "no GPS seconds" error. I've
> requested a firmware for the MTK3339 with $GPZDA sentences in case
> that fixes it.

Any NMEA setence that yields the current time is seconds will do.  Sometimes
you just eed to let it run a long while (30 mins) to get itself oriented.

> Anyway, I'm getting around 5-10ms jitter at 10Hz, no PPS.

Short term yes, long term you will see a lot worse.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97701
        address@hidden  Tel:+1(541)382-8588

reply via email to

[Prev in Thread] Current Thread [Next in Thread]