[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] Disabling hotplugging and manually connecting to device

From: Ed W
Subject: Re: [gpsd-users] Disabling hotplugging and manually connecting to device
Date: Fri, 23 Dec 2011 12:51:54 +0000
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20111105 Thunderbird/8.0

On 22/12/2011 03:29, Pris Matic wrote:
Thanks for the reply. I tried to use gpsdctl, but I ran into an issue when removing a device (ie, gpsdctl remove /dev/ttyUSBx): The device gets removed from gpsd's pool, but I can no longer access the serial port the device belongs to until I physically reconnect the device. I tried this on two devices... one that uses a Prolific chipset (is an actual GPS), and another that uses an FTDI chipset (is not a GPS). The FTDI chipset is the one that causes the problem. However, using both simple serial port code (C/C++) and a gui based serial port comm/monitor (cutecom), I can connect, talk to and disconnect to either device as many times as I want (before gpsd tries to identify the FTDI device -- once that happens, the port in question is locked, or "busy" until I physically reconnect... even killing gpsd doesn't relinquish the port). Is this a bug? I'm using gpsd 3.3 on Arch Linux, on an x86 machine.

There are quite some kernel bugs relating to serial ports, so check for these first.

However, yes, I notice some "oddities" relating to removing devices which haven't had all open filehandles on the device closed. For me these are usually visible using "fuser" though and *why* they occur can be complex, but killing the relevant processes will always fix things for me.

Good luck

Ed W

reply via email to

[Prev in Thread] Current Thread [Next in Thread]