[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-users] Building gpsd 3.3

From: Pris Matic
Subject: [gpsd-users] Building gpsd 3.3
Date: Thu, 22 Dec 2011 23:59:27 -0500


I'm trying to build gpsd (my distro has a gpsd package that works
fine, but I need to modify source). I'm running Arch Linux x86, kernel
3.1 (latest stable). I tried to follow the build instructions but ran
into many problems.

1) Running scons inside the build directory errors out with the following:
gpsd :/usr/bin/ld: ntpshm.o: undefined reference to symbol
'log@@GLIBC_2.0'.... /usr/bin/ld: note: 'log@@GLIBC_2.0' is defined in
DSO /lib/ so try adding it to the linker command line

I tried adding LDFLAGS=-lm to my environment in the SConstruct file,
my shell environment, even directly passing the argument to scons when
I called it but none of these methods worked.

Then I commented out line 805 and unindented line 806 in SConstruct,
and gpsd seemed to build without any more errors. I don't know what
the implications of changing those lines were.

2) I tried running scons testregress. Every single test (all 74)
fails. I added "." in my path, like the build docs say. I also tried
running testregress after installation, but this fails as well.

3) I decided to try running gpsd anyway, using xgps to verify it was
working okay... which gives me this error:
  File "/usr/local/bin/xgps", line 624
    Base.gpsfields = map(lambda ((label, hook), widget): (hook, widget),
SyntaxError: invalid syntax

4) Finally, I try checking gpspipe's output, and it looks like gpsd is
actually working, which is great.

Is everything okay at this point? (can I get xgps working somehow
too?) Or is gpsd going to break on me at some point because I couldn't
complete the build process properly?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]