[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PCButton - tracking rect

From: Riccardo Mottola
Subject: Re: PCButton - tracking rect
Date: Mon, 27 May 2019 21:12:01 +0200
User-agent: GNUMail (Version 1.3.0)

Hi Sergii,

It is not easy to reproduce

On 2019-05-22 10:34:36 +0000 Sergii Stoian <address@hidden> wrote:

With windowmaker, some tooltips work, sometimes they don't show, the
behaviour is
- move pointer over button
- TT doesn't show

In my case, TT moves with mouse cursor (as it should).

Here too, once it shows. By the first time the mouse is on the button, the TT may not show, with the behaviour I will describe again. If then he mouse is moved again, it will show and then track as it should.

- while it doesn't show, the WindowMaker icon gets grey (looses
Application Icon) and sometimes even jumps (focus lost?)

I didn't quite understand what you mean by "gets gray" - it becomes
stippled/highlighted as when application starts, just tile remains without
application icon or appicon completely disappears?

- slight mouse move over the same "target", ToolTip appears and
WindowMaker shows app icon again, everything fixed

I can't reproduce it. But my setup:
- based on gui/back 0.25.0
- use ART backend;
- parts of WindowMaker I've incorporated into NEXTSPACE's Workspace
contains my fixes and enhancements (including focus handling area);
What is your setup? Could you try to reproduce this with ART backend?
If you use master branch of gui/back you should observe problems with text
drawing (0.25.1 includes NSStringDrawing rewrite and broke ART in that
area) but window management should be OK.
I'm afraid I need a couple of weeks to create alternate setup. I'm busy
with preparing of NEXTSPACE 0.85 release now.

I still have one laptop wth ART and tried, the behaviour is slightly different (no grey icon) but the tooltip doesn't show sometimes and will show by moving the mouse again. That is, regarding the Button and TT, it behaves the same

The behaviour is
- start with a minimal desktop of windowmaker, no other apps besides xterm - move with one continous movement the mouse on a ProjectCenter button (I use the toolbar)
- the second or third button (but usually the first time it works)
  * the tooltip doesn't show
* on certain systems, at the same time, the app icon becomes totally grey, that is, it looses even the standard icon it had (e.g. the ProjectCenter icon), totally empty and stays so. As if WindowMaker had no clue about which app it was... * moving the mouse on the same button (or sometimes waiting long...) makes the ToolTIp appear and, in case, the Application Icon comes again!

Added confusion: opening apps (non-gnustep) , e.g. a browser and other windows and getting back to ProjectCenter everything seems to work! TT shows! closing the other apps keeps PC working TT, however clong and restarting PC, makes it act up again. That is, no restart of WindowMaker is needed to "reproduce" the issue.

It doesn't look cairo or art depdent.

Also, I tried on another system where I run XFCE and the issue doesn't happen, so I think it is indeed an interaction with WindowMaker.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]