[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-bugs] <bug>: 0.6.rc3 still no luck printing meds (agains

From: Jim Busser
Subject: Re: [Gnumed-bugs] <bug>: 0.6.rc3 still no luck printing meds (agains
Date: Fri, 08 Jan 2010 16:04:57 -0800

On 2010-01-08, at 4:21 AM, Karsten Hilbert wrote:

> But different error:
>> 2010-01-07 16:32:41  DEBUG     gm.gui 
>> (/home/jbusser/gm/06rc3/Gnumed/wxpython/
>>  #49): unhandled exception caught:
>> Traceback (most recent call last):
>>  File "/home/jbusser/gm/06rc3/Gnumed/wxpython/", line 
>> 1282, in _on_print_button_pressed
>>    self._grid_substances.print_medication_list()
>>  File "/home/jbusser/gm/06rc3/Gnumed/wxpython/", line 
>> 1056, in print_medication_list
>>    print_medication_list(parent = self)
>>  File "/home/jbusser/gm/06rc3/Gnumed/wxpython/", line 
>> 748, in print_medication_list
>>    meds_list = template.instantiate()
>> AttributeError: 'NoneType' object has no attribute 'instantiate'
> handling of that situation is now improved in CVS

so I downloaded a fresh cvs and tried running from it but lacked some kind of 
permission ??

address@hidden:~$ cd gm/cvs/gnumed/gnumed/client
address@hidden:~/gm/cvs/gnumed/gnumed/client$ ./
GNUmed startup: Running from local source tree.
Creating module import symlink ...
real dir: /home/jbusser/gm/cvs/gnumed/gnumed/client
    link: /home/jbusser/gm/cvs/gnumed/gnumed/Gnumed
Traceback (most recent call last):
 File "wxpython/", line 460, in <module>
 File "wxpython/", line 177, in setup_python_path
   os.symlink(real_dir, link_name)
OSError: [Errno 13] Permission denied
address@hidden:~/gm/cvs/gnumed/gnumed/client$ sudo ./
[sudo] password for jbusser: 

GNUmed startup: GNUmed should not be run as root.

Running GNUmed as <root> can potentially put all
your medical data at risk. It is strongly advised
against. Please run GNUmed as a non-root user.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]