[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 1.3.145 fonts mismatch

From: Mats Bengtsson
Subject: Re: 1.3.145 fonts mismatch
Date: Thu, 05 Apr 2001 00:21:12 +0200

> I feel I am being blind or stupid, or both, but here goes.
> I have a bizarre problem with 1.3.145 and mismatched pfa/tfm fonts. It
> may have been around for a while, it is only apparent if I run
> lilypond directly (which I rarely do - hence only just noticing it). ly2dvi 
> has no problems
> If I run lilypond directly on any file I get
> lilypond /home/mark/docs/music/scores/compositions/
> GNU LilyPond 1.3.145
> Now processing: `/home/mark/docs/music/scores/compositions/'
> Parsing...
> Interpreting music...error: checksum mismatch for font file: 
> `/usr/local/share/lilypond/afm/feta16.afm' does not match: 
> `/var/spool/texmf/tfm/lilypond/1.3.145/feta16.tfm'
>  TFM: -674589194 AFM: -1213785866
>  Rebuild all .afm files, and remove all .pk and .tfm files.  Rerun with -V to 
> show font paths.
> LilyPond exited abnormally with code 1 at Tue Apr  3 16:59:13
> I have removed all the generated fonts. The afm fonts **are** the ones for
> this version.
> If I run ly2dvi on the same .ly file all goes fine. 

I'm sure you have already made the obvious checks that both
/usr/local/share/lilypond/afm/feta16.afm and
are not older than the current Lilypond installation.

> Am I missing something **really** simple? What is going on?
> I suspect ly2dvi is changing the environment so the problem
> disappears, but I am not sure how.
> Thanks for some wisdom on this.

Yes, it does set some variables. If I were you, I'd 
edit ly2dvi and add the flag -V to the call of lilypond
at line 304. Then you'll get a printout of which font files
are used which you could compare to the printouts of plain
'lilypond -V ...'


reply via email to

[Prev in Thread] Current Thread [Next in Thread]