[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

1.3.145 fonts mismatch

From: Mark Hindley
Subject: 1.3.145 fonts mismatch
Date: Tue, 3 Apr 2001 17:04:37 +0100 (BST)

I feel I am being blind or stupid, or both, but here goes.

I have a bizarre problem with 1.3.145 and mismatched pfa/tfm fonts. It
may have been around for a while, it is only apparent if I run
lilypond directly (which I rarely do - hence only just noticing it). ly2dvi has 
no problems

If I run lilypond directly on any file I get

lilypond /home/mark/docs/music/scores/compositions/
GNU LilyPond 1.3.145
Now processing: `/home/mark/docs/music/scores/compositions/'
Interpreting music...error: checksum mismatch for font file: 
`/usr/local/share/lilypond/afm/feta16.afm' does not match: 
 TFM: -674589194 AFM: -1213785866
 Rebuild all .afm files, and remove all .pk and .tfm files.  Rerun with -V to 
show font paths.

LilyPond exited abnormally with code 1 at Tue Apr  3 16:59:13

I have removed all the generated fonts. The afm fonts **are** the ones for
this version.

If I run ly2dvi on the same .ly file all goes fine. 

Am I missing something **really** simple? What is going on?

I suspect ly2dvi is changing the environment so the problem
disappears, but I am not sure how.

Thanks for some wisdom on this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]