[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: nokia 3220 questions

From: Pawel Kot
Subject: Re: nokia 3220 questions
Date: Fri, 14 Apr 2006 20:00:18 +0200


On 4/13/06, Martin Topping <address@hidden> wrote:
> I'm using gnokii version 0.6.12 (the most recent?) on a Compaq Presario 1246
> laptop running Ubuntu 5.10 Breezy Badger. The phone I'm using is a Nokia
> 3220, and the cable is a Mobile Manager MA-8620 USB Cable, which is, I
> think, an independent manufacturer's version of the DKU-5. Ubuntu identifies
> it as
> Bus 001 Device 002: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial
> Port

This one should be supported by pl2303 Linux kernel driver.

> I've identified my phone as an "AT" model, which gnokii seems happy with.
> The --version, --identify and --monitor commands work well enough.

AT model support is quite limited. Either by the driver itself or by
fthe functionality offered by the phone itself for the AT commands.
model = 6510 should work fine though.

> It has problems with other things though... for instance, it reads my SMS
> messages, but when I tell it to --delete a message it says it's done it but
> no message seems to have gone!

Enable debug (see FAQ how to do it) and show the output.

> Also a number of commands aren't implemented in the model, such as
> --createsmsfolder, or any of the wap commands.

That's correct. These functionalities are not provided by any AT
command set. Use nk6510 driver instead.

>  When I try the --sendsms
> command, gnokii tells me to insert the message text, and end with <cr>
> ctrl-D. But what exactly _is_ <cr>? I think I must have tried every

This is enter.

> possible combination of keys... and none of them worked. In the end I
> had to hit ctrl-C just to exit the --sendsms command, with the obvious
> result that no message was sent.
> I _can_ make it call a number. Which leads me to ask... is there any way to
> get it to make a "data call" - basically, can I use it as a modem for my
> laptop to access the internet? (That's what I really want to do with it)

Sure you can. But you don't do it with gnokii. Treat your phone as a
regular modem.

> A connected question: the FAQ leads me to believe that I could use gnokiid
> to use my old Nokia 3510 as a modem. Have I got that right? Could someone

I think 3510 may not have data transfer. If it does, you don't just
gnokiid for that. gnokiid is just for Nokia 5110, 5130, 6110, 6130,

> point me in the right direction to achieve this? And would it be possible to
> gnokii for my 3510 _and_ my 3220? Two instances of gnokii on the laptop at
> the same time? Two .gnokiirc files?

At the moment -- unfortunately yes. gnokii CLI doesn't have the option
of using different sections from the config.

> When I installed gnokii, I was watching the messages scroll by, and saw that
> gnokii "could not detect X" and disabled xgnokii accordingly. But I most
> certainly _do_ have X on my computer!

You mean the configure? It means that you don't have development libraries.

> In the FAQ, I saw a mention of .rpm and .deb packages being available. But
> all I found were tarred and gzipped files. Maybe if I found a .deb and
> installed that, xgnokii would work okay?

That should do it.

> If I did find and install a .deb, would I first have to uninstall the
> present package? And how would I do that?

It would be wise. You need to remove installed files manually.
Important is just gnokii binary and libgnokii files. And gnokii.pc.

As for Ubuntu you can do just apt-get install gnokii. Be sure you have
universe repository. Breezy (5.10) has quite old gnokii version
though. I would recommend using Dapper (6.06) or building package from
scratch (gnokii provides build scripts for Debian based distros).

> Sorry for the silly questions, but I'm very new to any computing other than
> Windows-based point and click web surfing. I am slowly getting my head round
> this stuff, but I'm a slow learner ;)
> Finally, a "bug report" - but the "bug" is, I think, with the phone and/or
> cable rather than gnokii. When I connected this last time, the phone just
> wouldn't initialise... til I unplugged the cable, turned the phone off and
> on, and plugged it back in.
> Thanks folks!

take care,
Pawel Kot

reply via email to

[Prev in Thread] Current Thread [Next in Thread]