[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Nokia 6021 + IRDA: workin from time to time. [SOLUTION!]

From: Pavel Khmelinsky
Subject: Re: Nokia 6021 + IRDA: workin from time to time. [SOLUTION!]
Date: Fri, 14 Apr 2006 02:33:37 +0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060302

After hard googlin i found solution on this page:

The solution is
echo 9600 > /proc/sys/net/irda/max_baud_rate
bcos m600 driver broken.

Let me quote this page:
As you would guess, the echo 9600 line limits the rate of the IrDA dongle to 9600bps. This is because the MA620 driver is still being worked on and there's a small bug that causes problems at higher speeds.

On submitting this problem to the irda-users mailing list, Martin Diehl suggested a small change in the kernel. I quote him:

Simply try editing the file linux/drivers/net/irda/ma600-sir.c. In line 197 (2.6.7-vanilla) change the "#if 1" to read "#if 0" and rebuild your module. By chance this will help you out because the speed chance was likely working, just the verification failed.

Being part of the ``Top 10 Clueless About Kernel List'', I blindly followed his suggestion and rebuilt the kernel, and lo and behold, suddenly I could use the dongle at higher speeds.

With Martin's change in place I've so far used the USB port at up to 115200bps without problems. The speed still kind of sucks when transferring MP3s to the phone (more about that later), but baby, let me tell you, it's definitely an improvement over 9600bps!
<===END OF QUOTE====>

Pavel Khmelinsky wrote:

I have Nokia 6021 and USB-Irda adapter which actually USB<->COM<->IRDA adapter as i think.
It's using pl2303 module and attaching to /dev/ttyUSB0 when i plug it.

So for setup my irda I am using commands:
modprobe ma600-sir
modprobe irtty-sir
irattach /dev/ttyUSB0 -d ma600 -s

# lsmod | grep ir
rtty_sir               7936  2
ma600_sir               3968  1
sir_dev                18620  2 irtty_sir,ma600_sir
irda                  129720  4 ma600_sir,sir_dev
crc_ccitt               3072  1 irda

then i starting gnokii. And some times it's work. But for sure only once. If it's workin and i stop the program next time when i start it it will report:
Serial device: opening device /dev/ttyUSB0
Default: Nokia 6021     df2d
connect: No route to host
Couldn't open PHONET device: No route to host
Error in link initialisation: 1
GSM/FBUS init failed! (Unknown model?). Quitting.
Serial device: closing device

And after reboot it could work and could not.
When it's not workin i tried
echo 115200 > /proc/sys/net/irda/max_baud_rate
Didn't helped.

I also tried remove all modules and use this:
modprobe irda
modprobe irtty-sir
irattach /dev/ttyUSB0 -s
In that case  lsmod looks like
# lsmod | grep ir
irtty_sir               7936  2
sir_dev                18620  1 irtty_sir
irda                  129720  1 sir_dev
crc_ccitt               3072  1 irda

In irdadump i am seening my devices but i didn't ever have luck with gnokii with such modules.

Most strange thing is that sometimes it work. It' ever show me my address book but segfaulted on the middle of it.

Any ideas where to search for? Any troubleshooting guide?


gnokii-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]